面试官:说说http状态码,4开头和5开头具体有什么区别?

共 1004字,需浏览 3分钟

 ·

2021-04-10 11:02








关注公众号 前端人,回复“加群”

添加无广告优质学习群


访问网站所反应的信号叫做HTTP状态码,是以三个数字为主的,我们看不到只是浏览器可以检测到这样的信号。

也就是用以表示网页服务器HTTP响应状态的3位数的数字代码,http状态码是由RFC2616规范定义的,并得到了RFC 2518、RFC 2817、RFC 2295、RFC 2774、RFC 4918等规范扩展。

http状态码的第一个数字代表了相应的一种状态,通常共有五种状态形式。

5开头的http状态码

代表了服务器在处理请求的过程中有错误或者异常状态发生,也有可能是服务器意识到以当前的软硬件资源无法完成对请求的处理。

除非这是一个HEAD 请求,否则服务器应当包含一个解释当前错误状态以及这个状况是临时的还是永久的解释信息实体。浏览器应当向用户展示任何在当前响应中被包含的实体。这些状态码适用于任何响应方法。

4开头的http状态码

代表了客户端看起来可能发生了错误,妨碍了服务器的处理。除非响应的是一个 HEAD 请求,否则服务器就应该返回一个解释当前错误状况的实体,以及这是临时的还是永久性的状况。这些状态码适用于任何请求方法。

浏览器应当向用户显示任何包含在此类错误响应中的实体内容。

如果错误发生时客户端正在传送数据,那么使用TCP的服务器实现应当仔细确保在关闭客户端与服务器之间的连接之前,客户端已经收到了包含错误信息的数据包。

如果客户端在收到错误信息后继续向服务器发送数据,服务器的TCP栈将向客户端发送一个重置数据包,以清除该客户端所有还未识别的输入缓冲,以免这些数据被服务器上的应用程序读取并干扰后者。

参考资料

  • http://www.xiaokaiseo.com/255.html




最后

当前题目进度:虾皮一卷[10/10]题,虾皮第一卷正式完结,下周将是阿里的面试题套卷了哦,大家记得来打卡学习

关注公众号,置顶公众号,鬼哥每天解答一道大厂面试题,一起前端进阶

公众号里回复关键词加群,加入前端进阶群
坚持不易,希望能够帮助到一部分人,多谢帮忙一键三连


点击关注我们↓


套卷所有题目都在这个题库小程序↓


浏览 250
点赞
评论
收藏
分享

手机扫一扫分享

分享
举报
评论
图片
表情
推荐
点赞
评论
收藏
分享

手机扫一扫分享

分享
举报